canvas浏览器兼容性检测

在不兼容的情况下,尽量使用可代替的方法来实现相同功能

[code]
<canvas id="canvas" style="display: block;margin:0 auto;">
请使用高版本的浏览器!
</canvas>

<script>
var canvas = document.getElementById("canvas");
canvas.width = 800;
canvas.height = 800;
var cantext = canvas.getContext(‘2d’);
if(context.ellipse){
context.beginPath();
context.ellipse(400,400,300,200,0,0,Math.PI*2);
context.stroke();
}else{
alert("no ellipse");
}
</script>
[/code]

发表评论

邮箱地址不会被公开。 必填项已用*标注